PCCar.ru - Ваш автомобильный компьютер

Вернуться   PCCar.ru - Ваш автомобильный компьютер > MP3Car ТехИнфа > Беcпроводные коммуникации > Wi-Fi

Ответ
 
Опции темы
Старый 30.11.2017, 00:59   #1
Alex_St
Старший Пользователь
 
Аватар для Alex_St
 
Регистрация: 09.04.2008
Возраст: 38
Город: Одесса
Регион: Украина
Машина: Chevrolet Aveo-II LS 2008
Сообщений: 885
Alex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to all
По умолчанию Как настроить WiFi клиент на роутере с OpenWrt

Всем привет!
Имеется Wi-Fi роутер TP-Link TL-MR3420. На нем стоит прошивка OpenWrt.
Роутер будет стоять в машине и отвечать за подключение к Wi-Fi точкам доступа и к 3G посредством USB 3G модема.
Уже настроил приоритетное включение разных источников интернета при помощи балансера MWan3, чтобы роутер автоматически брал инет только с одного источника. Т.е. роутер подключен одновременно ко всем возможным источникам, но, если есть проводное подключение с интернетом (wan) - инет берет только оттуда. Если его нет, но есть подключение к сети Wi-Fi (wwan) - то оттуда. А если нет ни того, ни другого - то тогда используется инет с 3G свистка (wwan3g). Раздает все это через Ethernet.

Но столкнулся с любопытной проблемой - как настроить Wi-Fi в линуксе в роли станции, да так, чтобы он мог подключиться автоматически к любой из знакомых сетей. Например - машина стоит около дома - Wi-Fi клиент роутера автоматически подхватывает домашнюю сеть. Приехал на работу - Wi-Fi клиент роутера автоматически подхватывает рабочую сеть. И так со всеми знакомыми сетями - заправки, мойки, друзья, и т.д.
В файле /etc/config/wireless можно прописать несколько сетей. Но почему-то роутер подключается только к одной из них, пока принудительно не подключишь к другой. Причем - к одной из них подключается нормально, а на второй - не получает адрес по DHCP. Если в конфиге оставить только одну сеть - то все работает как часики.

Конфигурационные файлы у меня такие:
/etc/config/wireless:
Код:
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option txpower '18'
        option country 'UA'
        option channel '6'

config wifi-iface
        option ssid 'Сеть1'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'mac1'
        option key 'пароль1'
        option network 'wwan'

config wifi-iface
        option ssid 'Сеть2'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'mac2'
        option key 'пароль2'
        option network 'wwan'
/etc/config/network
Код:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc1:6662:1aab::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option metric '0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option metric '10'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'
        option _orig_bridge 'false'


config interface 'wwan3g'
        option proto '3g'
        option device '/dev/ttyUSB0'
        option service 'umts'
        option apn '3g.utel.ua'
        option pincode '1234'
        option dialnumber '*99***1#'
        option metric '30'
Подскажите, плз, в какую сторону копать.
__________________
Мой журнал: http://www.pccar.ru/showthread.php?p=79335
Alex_St вне форума   Ответить с цитированием
Старый 07.02.2018, 15:26   #2
kostya740
Старший Пользователь
 
Регистрация: 18.10.2008
Возраст: 35
Город: Одесса
Регион: Украина
Машина: 1999\BMW\E38 740
Сообщений: 834
kostya740 is a jewel in the roughkostya740 is a jewel in the roughkostya740 is a jewel in the rough
По умолчанию

нельзя одновременно и клиент и wifi точка.
для этого тебе нужен второй USB wifi свисток, втыкнутый в роутер.
kostya740 вне форума   Ответить с цитированием
Старый 07.02.2018, 15:31   #3
Alex_St
Старший Пользователь
 
Аватар для Alex_St
 
Регистрация: 09.04.2008
Возраст: 38
Город: Одесса
Регион: Украина
Машина: Chevrolet Aveo-II LS 2008
Сообщений: 885
Alex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to allAlex_St is a name known to all
По умолчанию

Спасибо за ответ. Но мне не нужно одновременно клиент и точка. Мне нужен только клиент, но который будет подключаться к любой из известных сетей, как на мобилке.
__________________
Мой журнал: http://www.pccar.ru/showthread.php?p=79335
Alex_St вне форума   Ответить с цитированием
Старый 07.02.2018, 18:06   #4
admin
Administrator
 
Аватар для admin
 
Регистрация: 15.06.2005
Город: Москва
Регион: 77, 97, 99, 177
Машина: Lexus RX400h
Сообщений: 768
admin is a glorious beacon of lightadmin is a glorious beacon of lightadmin is a glorious beacon of lightadmin is a glorious beacon of lightadmin is a glorious beacon of lightadmin is a glorious beacon of light
По умолчанию

Про OpenWRT здесь поищи или спроси http://cyber-place.ru/forumdisplay.php?f=38
__________________
Все для arduino.
admin вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Часовой пояс GMT +4, время: 16:13.


Работает на vBulletin® версия 3.8.4.
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Перевод: zCarot
Яндекс.Метрика